联系我们联系我们

动向速度比率指标用法及源代码(SRDM)

时间:2019-04-18 19:42来源:操盘手联盟 作者:CFTSC 点击:
指标源代码 N=30 DMZ:=IF((HIGH+LOW)=(REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1)))); DMF:=IF((HIGH+LOW)=(REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1)))); ADMZ:=MA(DMZ,10); ADMF:=MA(DMF,10
动向速度比率


指标源代码
N=30
DMZ:=IF((HIGH+LOW)<=(REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
DMF:=IF((HIGH+LOW)>=(REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
ADMZ:=MA(DMZ,10);
ADMF:=MA(DMF,10);
SRDM:IF(ADMZ>ADMF,(ADMZ-ADMF)/ADMZ,IF(ADMZ==ADMF,0,(ADMZ-ADMF)/ADMF));
ASRDM:SMA(SRDM,N,1);


指标用法同KD指标

KDJ指标说明
KDJ,其综合动量观念、强弱指标及移动平均线的优点,早年应用在期货投资方面,功能颇为显著,目前为股市中最常被使用的指标之一。
买卖原则
1 K线由右边向下交叉D值做卖,K线由右边向上交叉D值做买。
2 高档连续二次向下交叉确认跌势,低挡连续二次向上交叉确认涨势。
3 D值<20%超卖,D值>80%超买,J>100%超买,J<10%超卖。
4 KD值于50%左右徘徊或交叉时,无意义。
5 投机性太强的个股不适用。
6 可观察KD值同股价的背离,以确认高低点。

具体解释
//如果高点加低点的价格小于等于昨天的高点加低点的价格,则返回0,否则返回 当根k线的高点与上根k线的高点的差值的绝对值与当根k线的低点与上根k线的低点的绝对值中较大者;
DMF:=IFELSE((HIGH+LOW)>=(REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
//如果当根k线的高点加低点的价格大于等于昨天的高点加低点的价格,则返回0,否则返回 当根k线的高点与上根k线的高点的差值的绝对值与当根k线的低点与上根k线的低点的绝对值中较大者;
ADMZ:=MA(DMZ,10);//DMZ值的10日简单移动平均;
ADMF:=MA(DMF,10);//DMF值的10日简单移动平均;
SRDM:IFELSE(ADMZ>ADMF,(ADMZ-ADMF)/ADMZ,IFELSE(ADMZ=ADMF,0,(ADMZ-ADMF)/ADMF));//如果ADMZ>ADMF,则返回(ADMZ-ADMF)/ADMZ,否则当ADMZ=ADMF时返回0,小于时返回(ADMZ-ADMF)/ADMF;
ASRDM:SMA(SRDM,N,1);//SRDM值的N日以1为权重的移动平均;
CROSS(SRDM,ASRDM),BPK;//SRDM上穿ASRDM,买平开;
CROSS(ASRDM,SRDM),SPK;//ASRDM下穿SRDM,卖平开;
AUTOFILTER;





------分隔线----------------------------
期货操盘手选拔
风险提示:期市有风险,入市需谨慎;独立思考决策,不频繁交易。
@2017 CFTSC 操盘手联盟工作室,欢迎您的加入,携手共创美好明天。
期货操盘手选拔软件下载

电脑交易软件下载


快期下载
开拓者下载
博弈大师下载

手机交易软件,亲扫二维码
下载,或在苹果商城、安
卓360商城搜 知富通 下载。